JMRI: Turnouts Documentation

What are Turnouts?

JMRI calls just about any output to the layout a "Turnout". Originally, JMRI controlled just Turnouts via DCC accessory decoders. As time went on, JMRI added more capability, but has kept that name. Now, for example, the individual output pins on a C/MRI system are also referenced via the "Turnout" name.

How to setup Turnouts

Turnout Properties

Turnouts are created and edited in the Turnout Table.
A range of columns shows the settings for each Turnout.
Along the bottom are checkboxes to display additional columns.

Controlling a Turnout

The two states of the output are called "Closed" and "Thrown". "Closed" is the off, inactive, not commanded state. "Thrown" is the on, active, commanded state.

In most cases, you can just operate a Turnout and JMRI will figure out what you mean. For example, you can open the "Turnout Control" tool from the "Tools" menu, enter a Turnout number (DCC or C/MRI address number), and click Thrown or Closed. JMRI will take it from there.

Saving Turnout configuration to disk

The Turnout definitions are kept in your layout configuration, along with Sensors, Signal Heads, control panel setup etc. To store this information on disk, allowing to reload it next time you run JMRI, use Store Configuration... in the File menu at the top of the Turnout Table (or other tables from the Tools menu), or select Store Panel... in the Panel menu.

Adding a new Turnout

To fully configure a new Turnout, follow this procedure:

  1. Click Tables -> Turnouts in the Tools menu to bring up the Turnout Table, and click the Add... button at the bottom of the pane to bring up the Add/Edit Turnout pane.

  2. From the System drop down list select the system to which the Turnout address is connected to. In the Hardware Address field enter the dcc accessory address of the Turnout.

  3. Enter a User Name. Any string of characters that is different from the User Name of other Turnouts will be accepted, but it's wise to use a string that describes the intended use of the Turnout. You can leave this blank if you'd like.

  4. If you wish to add a number of Turnouts at once, click on the Add a Range checkbox and then in the Number to Add field enter the number of Turnouts that you wish to add. If you have entered a User Name, then this will be appended with a number to ensure that each User Name is unique. If a hardware address already exists in the range that is being added, then the system will skip that address and carry on.

  5. Click the OK button at the bottom of the pane. If everything is fine, the new Turnout will appear in the Turnout Table. If there is trouble with anything, an error or warning message will be displayed on screen; you should correct the error and click OK again.

  6. Back in the main Turnout Table, you can now set options for the Turnout by clicking its Edit button, and control it by clicking its Cmd button.