Release Notes for JMRI 3.11.2 release

Date: January 13, 2015

From: Bob Jacobsen

Subject: Test version 3.11.2 of JMRI/DecoderPro is available for download.

Notes:

This is a test release. Please post a note if you encounter any new or old bugs! And please back up your JMRI files before installing this, in case you want to go back to an earlier version.

This is the next in a series of test versions. We expect this series to end in the next JMRI production release around the middle of 2015.

Some of the changes involved are quite extensive. They may require a certain amount of experience before they are working well. Therefore, this test version should be considered experimental.

JMRI is now only available under the GNU General Public License. For more information, please see our copyright and licensing page.

Known problems with this release

New warnings for this version:

None

Older warnings

This release, and all later releases in this cycle, require Java 1.8 or higher. To use this or any later JMRI releases, you'll have to update the Java on your computer to Java 1.8 or higher.

This release uses JDOM 2.0.5, which requires some code changes if you are directly calling the parts of JMRI that interchange XML objects.

There are now separate settings for the default Service Mode Programmer and for the default Ops Mode Programmer. If you're using two or more system connections, this lets you use one connection for ops mode (on track) programming and another connection for your programming track. If you're using two separate connections, you should go to the Defaults pane on the Preferences window and check that those defaults were set properly.

If you are making a direct connection to a Intellibox unit via serial or USB, you will have to reselect your preferences. See the Uhlenbrock support page for instructions.

If you are using an NCE USB adapter, you will have to reselect your preferences the first time you use a JMRI 3.11 version (if you set them using JMRI 3.10 or earlier). See the page on configuring JMRI for NCE for instructions.

Because of internal code changes, this version of JMRI is not compatible with CATS 2.34 or earlier. Keep using JMRI 3.10 with CATS until there's a CATS update that says it will work with JMRI 3.11.

The XmlIO web service has been removed. All users who were relying on the XmlIO API are recommended to begin using the JSON API. inControl web throttle users are recommended to begin using webThrottle instead, or invest in devices that can support webThrottle, the iOS WiThrottle, or the Android Engine Driver.

Download links:

Please use these links for downloading:

Mac OS X: https://sourceforge.net/projects/jmri/files/test%20files/JMRI.3.11.2-r28415.dmg/download

Windows: https://sourceforge.net/projects/jmri/files/test%20files/JMRI.3.11.2-r28415.exe/download

Linux: https://sourceforge.net/projects/jmri/files/test%20files/JMRI.3.11.2-r28415.tgz/download

Changes since test release 3.11.1:

Fixed problem where rebuilding the Roster can lose the existing roster groups.

Hardware Support

Fixed problems with programmers created during the programming mode migration:

New / Updated decoder definitions

ESU

Dave Heap fixed a problem with strange sound slot names displayed in LokSound Select.