The Switchboard Editor

since 4.7.3

Switchboards provide a visual control grid for your JMRI layout "out of the box".
To create a new Switchboard, from the Panels menu, choose New Panel ⇒ Switchboard Editor.
A default pane with switches for Turnouts in the range 1 - 24 opens.
If any Turnouts were defined in JMRI beforehand, those switches will immediately show their current state and immediately let you control them.

The Switchboard Editor

To the left, a small Switchboard Editor pane allows you to refine what this Switchboard will control. Select an option for:

Example of a Switchboard pane

Optionally, change the background color for this Switchboard via the Options menu. since 4.21.2The new settings are applied immediately. Sometimes you may want to click [Update Switchboard] to redraw all items on the board.

Note that hybrid Switchboards containing more than one bean type or connection are not possible. You can create and save separate Switchboards for different connections, address ranges and object types like Turnouts. Change the name of this Switchboard by choosing Rename Switchboard... from the Edit menu while the Editor is open.

When ready, close the Editor by clicking the Close box in its title bar or Close Editor from the File menu. Open the Editor at any time from the Switchboard's Edit menu.

Quick Reference Guide - Using the Switchboard

In the PanelPro Panel menu, select New > Switchboard Editor.

After the standard board opens, select a Connection, Bean type Switch Shape from the comboboxes.

Drag and resize the window to a handy position on screen. The switches will reflow and resize.

Clicking on an active switch on the board will send an instruction to the layout to toggle the item (on/off, closed/thrown). Depending on the hardware, the switch label and graphics will change to show the new state.

A tooltip appears when you hover your mouse over a switch, showing the user name of that item (if it's connected and set).

Right-click a switch to open a context-menu and:

SwitchBoard keys

Remember to save your setup and configured items by choosing Store Panels... from the File menu.
Note: The menu item changes as of 4.23.3 to Store ALL table content and panels. For details, see Loading and Storing Your Work.
You can have your Switchboards open automatically upon startup by setting them as as an "Open File" Startup Action under Preferences > Startup.

Back to the PanelPro help page.