Transit Table Help

All the Transits that JMRI knows about can be viewed using the Transit Table.

To open this tool, select Transits in the Tables submenu of the Tools menu of the main JMRI program window.

Using the Transit Table

Transits are set up in the Transit Table. When set up, Transits are independent of the Trains that use them.

All Transits that currently exist can be referenced using the Transits tool under Tables in the Tools menu of most JMRI programs. There are seven columns in the Transit Table:

To define a new Transit, click the Add... button. An Add/Edit Transit window will be brought up that will allow you to designate the Sections in the new Transit. (Obviously, Sections must be defined before any Transit can be created.) Since a Transit may be used in only one Active Train at a time, the Duplicate option (see above) may save time when creating multiple copies of the same Transit.

Using the Layout Editor to Set Up Transits

If you are using a Layout Editor Panel to define and generate the Logic for Signal Masts and Sections, it is possible to create a basic Transit from the Layout Editor. To do this, bring up the context menu (right-click) of a Signal Mast on the panel. If things have been set up correctly you will see the option to Create Transit From Here. After selecting that option you can progress along your route and select each facing Signal Mast, bringing up the context menu on each and selecting Add to Transit. When you are at the final destination Signal Mast on your route, select Add to Transit and Complete in the context menu of that last Signal Mast.
Please note that you will have to manually save the Transits to disk (see below).

Setting up for Continuous Running

A Transit may be set up for continuous running, allowing an Active Train to travel through its Transit multiple times without being terminated and re-activated. Provided its Transit is set up for continuous running, each time an Active Train completes traveling through its Transit, the Active Train optionally may be automatically reset by Dispatcher so it is ready to run through its Transit again. For a Transit to be capable of continuous running, its first Section and its last Section must be the same, and both must be set up for running in the same direction. This applies to both Manual and Automatic running of Trains.

For more information on setting the continuous running option, visit the Activate New Train Help.

Specifying Actions for Automatic Running

Transits support a variety of Actions that automatically happen when a Train is run through the Transit in Automatic mode. One or more Actions may be specified with each Section in the Transit. Action are initiated when their associated Section in the Transit is entered by the Automatically run Train.
Each Action has two parts:

A commonly used Action, for example, is "When the train starts, turn on its headlight." More information on Actions is located in the Actions. Read more on Actions.

Saving Transits to Disk

Use the Store item in the File menu to save Transit information to disk. This information is saved with the configuration in an XML file, along with control panel setup and similar items. To store your panels in the same file (recommended), select File -> Store > Store Configuration and Panels To File... or select Panels > Store panels... in the main JMRI window.

Back to Transits Documentation.