Section Table Help

Using the Section Table

All the Sections that JMRI knows about can be viewed using the Section Table.

To open this tool, select Sections in the Tables submenu of the Tools menu of the main JMRI program window.

Section Table Columns

You may change the order of the columns by dragging their titles, and sort the rows by clicking one of the sort triangles next to a column title. There are eight columns in the Section Table:

Creating a new Section

To Create a new Section, click the "Add..." button at the bottom of the Section Table pane. A window will be brought up that will allow you to define the blocks included in the new Section, and if necessary, designate which entry points to the section result in travel in the FORWARD and REVERSE directions.

Section Table Tools

The Section Table has a Tools menu to facilitate use of Sections. Normally these tools would be used after all Sections are defined. The menu items and their use are described below:

Saving Sections to Disk

Use the Store item in the File menu of the Section Table (or the Store Panels... item in the Panels menu of the main JMRI window) to save Section information to disk. This information (and any modified Signal Mast Logic information) is saved with the configuration and Panels in an XML file, along with Control Panel setup and similar stuff. To store your panels in the same file (recommended), select File>Store>Store Configuration and Panels To File... or select Panels>Store Panels... in the main JMRI window.

Back to Sections Documentation.